Unusual WordPress Update Message From Google in Console

By | February 7, 2017

Recommended WordPress update available for your site (Unusal WordPress Update Message by Google in Google Search Console)

Did you also get WordPress update message from Google Search Console Team? I don’t think we should need to worried about it. Today, I was checking my email and I was surprised to see an message from google console team about “Recommended WordPress Update availibility“. I thought may be wordpress has launched its new version and google wanted to update site’s wordpress version ASAP, Perhaps, escape from any security danger. Whereas, I always update to latest version after a release is out. In the Email, Google mentioned that “Google has detected that your site is currently running WordPress 4.7.0 or 4.7.1, an older version of WordPress”. It is something which surprised me because I am already using the latest version 4.7.2. Google also provided an example page for each site it flagged. Seems like Google try to play April Fool before April :). Do you know, how to determine Google Algorithm Updates.

Unusual WordPress Update Message From Google in Console [howpk.com]

Unusual WordPress Update Message From Google in Console [howpk.com]

Here is the Email Transcript:

Recommended WordPress update available for http://howpk.com/

Google has detected that your site is currently running WordPress 4.7.0 or 4.7.1, an older version of WordPress. Outdated or unpatched software can be vulnerable to hacking and malware exploits that harm potential visitors to your site. Therefore, we suggest you update the software on your site as soon as possible.

Following are one or more example URLs where we found pages that have outdated software. The list is not exhaustive.

http://howpk.com/2014-ferrari-price-in-pakistan-india/

http://howpk.com/admission-bahauddin-zakariya-university-multan/

http://howpk.com/flood-in-pakistan-2014-september/

After checking the flagged pages I came to know, the cached version of the example page was old enough to have 4.7.0 or 4.7.1.







Here are some of the comments from Google Support Forum

Just received a stack of “Google has detected that your site is currently running WordPress 4.7.0 or 4.7.1, an older version of WordPress” notices.  Had us puzzled here, since we update literally moments after a release is out.

 

Ah! We just received one of these and I’d never thought about an old cached page being the result of it, because like you, our WordPress is also up-to-date.

 

It’s annoying because more just keep coming through and ALL of my WP sites are running 4.7.2 I almost wish I didn’t have so many of them right about now…!

 

Yup, got these too — they are erroneous!
Already updated to WordPress 4.7.2 more than a week ago, and today here’s this email.This is not helpful, Google.

Are we in Danger!
Don’t know exactly. From last few weeks google digging more deep in site analysis. On December 2016, many webmasters face a huge drop in ranking as well as conversation. But here is a sign for all bloggers, Google still use old data of site.
What we can do?
All we can do is, delete all expire and old cahce of our website and submit for indexation. I don’t really think, google knock out any site due to the old software usage.
Let’s talk:
Have you also got such Enail? Let’s discuss on it. What you think about it? Feel free to share your views with us.
Author: Tanvir Zafar

Tanvir Zafar is a internet Entrepreneur and owner of this site and many others as well. He is student in GCUF doing BS Software Engineering. :)